Resolved
Estimate functionality has been restored.
Identified
We have identified the cause of the issue and are preparing a fix.
Investigating
We are aware of an issue causing estimates to not show as recorded for the round guests, preventing saving of effort levels in Linear.